Organisation sign-up issue
Incident Report for GovWifi
Resolved
This incident has been resolved.
Posted Mar 11, 2021 - 15:20 UTC
Investigating
We are currently investigating an issue with the organisation sign-up process.
Posted Mar 11, 2021 - 14:41 UTC
This incident affected: Admin Management Portal.